Version:
  1. Backwards compatible interface for modules

    Article: AN0001585 Displayed: 494x

    After installingn a new version of ObjectGears system it is necessary to install new version of all the modules that are used. If the new ObjectGears version is marked as "Backwards compatible interface for modules" = YES, than the module developer just needs to compile it against the new version of ObjectGears system (library Common) in Visual studio. There is no need for changes in the code. In comparison to the previous version the interface is same or extended by a new functionality. No function was removed, no function definition was altered.

    If the interface is marked "Backwards compatible interface for modules" = NO, it is necessary to change the module code. It is likely that some function from the interface was removed or altered.

    New versions of modules created by Terannum company can be found as new packages directly in the installer. In case of third party modules check the website of the particular vendor.

     

  2.    ---
    Your rating:
    Rated by users: 0x
  3. Top
SearchTitle
×